Cannot add ETH / Ledger wallet: "Failed to add wallet"

Hi,

I’ve got some ETH on a Ledger wallet and want to add it to my wallets.
The instructions say I should enter my public address.
When coping the address, I always get the error:
“Failed to add wallet. Please check the values below.”
Same for Ledger and “Public Address”.

I’m pretty sure that the address is correct, as Etherscan shows the correct transactions and balance for the address. How can I add my wallet/address?

Thanks!

3 Likes

That’s the same error i’m getting. Can someone get on this thread and respond? I know this is all about community, but its a pain in the ass when the most basic of features breaks. The public address + telling it that i’m adding a ETH wallet should be enough, but it just fails to add.

1 Like

Same issue here, would love some help.

1 Like

Same issue here as well. Pretty disappointed, this is a basic feature that should be working at least.

1 Like

Same here, I was ready to sign up with them but if this isn’t working and the response time is lagging now, what happens during tax season.

2 Likes

Same issue here. Can someone provide a fix please?

1 Like

Also waiting to get any update from Support on this issue - appears to be impacting a lot of people attempting to add ETH wallets.

I also am unable to add my MetaMask ETH wallet. I get the same error “failed to add wallet. Please check values below.” It would be great to have this corrected.

I get the same error message when trying to add an ETH / Trezor wallet. So obviously not just a Ledger issue. I contacted support 2 days ago, but no response from Cointracker yet.

So, I tried again to add my ETH / Trezor wallet this morning, and now I’m getting a different error message. It now says:

“The address can’t be added because it has zero transactions.”

Frustrating.

Okay, now this is getting even weirder. I have 2 ETH wallets on my Trezor. I was able to add one of my ETH wallets to Cointracker this morning. But the other ETH wallet still displays the error message:

The address can’t be added because it has zero transactions.

1 Like

Success - was finally able to add an ETH wallet a few mins ago. Could have been by luck as my support tickets were not responded to, but hope you all manage to do the same. thanks

I’ve got the exact same issue. Can add 1 of 2 ETH addresses from my Ledger, but the other gives me the “zero transactions” error (which is not true).

Any tips from anyone?

I am also now getting the “zero transactions” statement opposed to the previous error message

FWIW, I could successfully add my ETH address now.

Hi all,

I can confirm that you need to have transactions associated with your ETH address before you can add it to CoinTracker. It’s not possible to add a wallet or exchange with 0 transactions. You need to make a transaction first and then sync the wallet/exchange.

Previously the error message would have been the generic one you’ve mentioned: “Failed to add wallet. Please check the values below.”

We’re trying to make error messages clearer and so you may now see “The address can’t be added because it has zero transactions” instead if this is what’s preventing you connecting your Metamask/ETH address.

Henry - i’m pleading with you - the can’t add wallet error is beyond frustraing. Its like you want to be unemployed because you don’t want me to give you crypto gains by fixing this stupid error about not be able to add a wallet because it “THINKS” my wallet is already assocaited. Help a brother out and just open my support ticket and respond. It’s cool some people got their wallets to add eventually - but the rest of us are out here suffering like we know wtf gains we have cause we tracked it on pen and paper. HALP!

Hey - I’ve followed up on your support ticket. Let’s continue the conversation there (you’ll see my response in your emails).

I am having the same issues. I spent hours loading up all my wallets and exchanges, but only my ETH metamask wont load… says, “Failed to add wallet. Please check the values below” and sometimes says something about zero balance! I even moved some ETH around in and out of the wallet just to make sure it was working properly on the metamask side. I also checked and everything shows up fine on etherscan. I do have BSC and AVAX chains activated on the same metamask wallet address, and those load fine… its just ETH that doesn’t load. Have any of you resolved this issue?

I HAVE been successful in adding the same ETH metamask wallet in a few other tax apps I’ve been testing out (Koinly, Cryptotrader, etc), and it works perfectly on those platforms… there are some reasons I like Cointracker… but if I can’t solve this issue I will have to use another platform!

Hi, Same issue with adding ETH TXs from MetaMask or as a public address.