Fees not deducted from Exchange Wallets

Hello Cointracker Team,

I’m almost finished setting up my last four years transactions in Cointracker, but have noticed a bug specific to fees in manually imported exchange wallets not being deducted from the running balance. Unfortunately I have hundreds of these types of transactions across three wallets. I have a period of time that had to be manually imported for Kraken, and even though the fee shows properly on the transactions it does not get deducted from the balance. Here is an example where the balance should end up being zero:

The problem is that this balance just keeps getting higher and higher each time I transfer Bitcoin out. I also have the same issue with my manually imported Paxful and LocalBitcoins wallets. Here is the Paxful example:



I have already had to go through and do thousands of manual changes to transactions for other issues, but I’m not even really sure how to manually fix this problem since the fee shows up and is already input correctly?

Hi @LukeBlodgett,

You’re right. We are going to work to systematically update this for cases where the sent amount is not included in the “Sent Quantity” field. A short term workaround is to add the fee amount to the “Sent Quantity.”

Alright, will do…

1 Like

@Chandan So how is progress with this issue… over 12months have passed and I am still having this issue. Has this been fixed? or am I going mad and doing something wrong?

I have manually imported all my transactions from localbitcoin. All fees inputted correctly… but they are not being deducted from my balance. My balance should be zero now but its shows by coincidence the total cost of my fees as a credit in the wallet?

confirm same bug
( is a year short term?)

I found this same problem and reported it to support a couple months ago but never heard back. This is happening on directly imported exchange data. You can’t possibly expect us to go through and manually modify thousands of transactions to get this data right?? How can you accurately produce tax documents with this bug present?? I can’t believe this is sitting open for over a year…

FWIW: After posting this message here, I had someone from support respond to my original email on this subject from June telling me that they updated the internal ticket with my notes.