"this transfer results in a negative balance"

I’m trying to clean up my wallets but am finding some errors which I can’t clean up. It is unclear if I can safely ignore these issues. I get the message “This transfer results in a negative balance in Other Transactions” even though the attached screen shots clearly demonstrate that there should be no negative balance. And these examples are boiled down to the most simple cases where it should be obvious. What’s going on?

Hi @cacortes,

In all of these cases (for example:)

In this screenshot, the bottom transaction is showing a different version of VTHO (with icon) than the top transaction (no icon). They have the same symbol but the coin probably went through a chain or contract swap. To make them consistent, just edit the no-icon transactions and select the version with the VTHO icon.

@Chandan, is it also possible to cause this when manually adding transactions, and typing the coin, rather than selecting from the dropdown box?

@sforman52 could you clarify what you mean? In the dropdown, we shouldn’t give an option to add a coin that isn’t either:

A) synced via our system with a logo
B) a custom added currency added by the user

Here’s what I’m talking about. I start typing a coin name, and the selections appear below. I can move to another field on the page without selecting anything, and the logo remains blank.

image

I tested this, and once it saves, it does populate correctly.

Thanks for clearing this up. I can now fix my issues.

I was thinking that you should be able to automate this process, but I think it’s an issue for coins that have had more than one manifestation. E.g. EOS went from being an ERC-20 token to running on its own blockchain. But perhaps the way for your system to get smart about it is to attempt to guess the correct underlying coin by choosing the latest and then flagging it. The other option is to just flag when the icon is missing with a link to instructions.

Thanks.

1 Like

Hi @cacortes,

Great! We will work on improving this

Hi @sforman52,

Here’s what I’m talking about. I start typing a coin name, and the selections appear below. I can move to another field on the page without selecting anything, and the logo remains blank.

image

I tested this, and once it saves, it does populate correctly.

Sorry, didn’t understand your issue here. Were you able to resolve or are you still facing a problem? If you select the correct coin with the logo are you still having a problem?

It worked as I expected. I was showing that I could file with “BTC” without selecting the coin, but saving filed it properly in the database.

1 Like